큐브리드2012.08.25 21:29


맥 OSX에서 사용할 수 있는 Java/RCP가 아닌 Cocoa CUBRID Client 개발을 위해 1차로 CUBRIDCocoa라는 이름으로 드라이버 개발을 시작합니다.


주말에 1~2시간 내어서 하는 개인 프로젝트라 계획한 마일스톤에 맞출 수 있을지는 모르겠지만, CUBRID 클라이언트 지원이 많아지기를 기대하며 시작합니다.


CUBRID cci는 32/64bit 빌드를 하여 프로젝트에 추가하였고, Xcode framework project로 생성하여 기본 레이아웃만 잡은 상태 입니다.


목표는 cci의 c-api가 아니라 objective-c 타입의 api로 개발하는 것입니다.


프로젝트 및 이슈 트래커는 github에서 유지합니다.

https://github.com/newpcraft/CUBRIDCocoa


Posted by 종이비행기
개발과삶2011.07.23 15:30
일반적으로 iPhone Simulator로 빌드를 하려고 할 경우 static library가 i386으로 빌드되지 않은 경우 Project의 Build Settings를 보면 Valid Architectures 항목에 armv6 armv7만 있을 경우가 더러 있습니다.
그렇게되면 시뮬레이터로는 빌드가 되지 않으며 "No architectures to compile for (ARCHS=i386, VALID_ARCHS=armv6 armv7)" 에러가 나게 됩니다.

해결방법은, Valid Architectures 항목에 i386만 추가해주면 됩니다.


라이온 덕분에 Xcode3에서 Xcode4로 전환하는데 비용이 많이 드는군요. 빌드가 잘 되던 프로젝트들이 에러를 툭툭 뱉어내고 있습니다. ㅠㅠ
Posted by 종이비행기

티스토리 툴바